lxc: disable lua and python
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 5 Jul 2014 23:34:01 +0000 (20:34 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 6 Jul 2014 20:52:30 +0000 (22:52 +0200)
Also conditionally disable bash if bash isn't built. Fixes:
http://autobuild.buildroot.net/results/8ea/8ea1d682706ba5fee27a64008bb7237d53120e9b/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/lxc/lxc.mk

index b251b1429f30231e6564e9ec3deb988df625f638..abb0a1bdf4e905b674789635a0316861a888816e 100644 (file)
@@ -11,6 +11,8 @@ LXC_LICENSE_FILES = COPYING
 LXC_DEPENDENCIES = libcap host-pkgconf
 # configure not shipped
 LXC_AUTORECONF = YES
-LXC_CONF_OPT = --disable-apparmor --with-distro=buildroot
+LXC_CONF_OPT = --disable-apparmor --with-distro=buildroot \
+       --disable-lua --disable-python \
+       $(if $(BR2_PACKAGE_BASH),,--disable-bash)
 
 $(eval $(autotools-package))