package/sg3_utils: link with libatomic when needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 26 Apr 2020 07:21:16 +0000 (09:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 27 Apr 2020 20:46:19 +0000 (22:46 +0200)
sg3_utils uses __atomic_fetch_add_4 since version 1.45 and
https://github.com/hreinecke/sg3_utils/commit/e9445f4efc012d37809342ba21f16360a0208f06

Fixes:
 - http://autobuild.buildroot.org/results/7773ead32375ca9073f45db83dac299aa2edd619

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sg3_utils/sg3_utils.mk

index 4685169e39857744c77e505521c6b207029d8a15..11b3691ffc40200d27dc6defd378785cb4ad0ab3 100644 (file)
@@ -20,6 +20,11 @@ SG3_UTILS_AUTORECONF = YES
 # install the libsgutils2 library
 SG3_UTILS_INSTALL_STAGING = YES
 
+# Uses __atomic_fetch_add_4
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+SG3_UTILS_CONF_ENV += LIBS="-latomic"
+endif
+
 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),)
 define SG3_UTILS_REMOVE_PROGS
        for prog in \