New package: parted
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 12 Mar 2012 10:24:04 +0000 (11:24 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 13 Mar 2012 12:59:05 +0000 (13:59 +0100)
[Peter: needs largefile + wchar]
Signed-off-by: Nicolas Dechesne <n-dechesne@ti.com>
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/parted/Config.in [new file with mode: 0644]
package/parted/parted.mk [new file with mode: 0644]

index 4838edc80ee5913058f2c1057485cb4e678c1f2d..36a221cfb07e44d72d362ead000fa0e8b39898ff 100644 (file)
@@ -202,6 +202,7 @@ source "package/mtd/Config.in"
 source "package/ntfs-3g/Config.in"
 source "package/open2300/Config.in"
 source "package/openocd/Config.in"
+source "package/parted/Config.in"
 source "package/pciutils/Config.in"
 source "package/picocom/Config.in"
 source "package/rng-tools/Config.in"
diff --git a/package/parted/Config.in b/package/parted/Config.in
new file mode 100644 (file)
index 0000000..610c040
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_PARTED
+       bool "parted"
+       depends on BR2_LARGEFILE
+       depends on BR2_USE_WCHAR
+       select BR2_PACKAGE_LVM2
+       select BR2_PACKAGE_READLINE
+       select BR2_PACKAGE_UTIL_LINUX
+       help
+         parted, the GNU partition resizing program
+
+         http://www.gnu.org/software/parted/
+
+comment "parted requires a toolchain with LARGEFILE+WCHAR support"
+        depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
diff --git a/package/parted/parted.mk b/package/parted/parted.mk
new file mode 100644 (file)
index 0000000..c4107e7
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# parted
+#
+#############################################################
+
+PARTED_VERSION = 3.1
+PARTED_SOURCE = parted-$(PARTED_VERSION).tar.xz
+PARTED_SITE = $(BR2_GNU_MIRROR)/parted
+PARTED_DEPENDENCIES = readline util-linux lvm2
+PARTED_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS))