package/kodi: add optional support for libvdpau
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 11 Jul 2016 18:09:01 +0000 (20:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Jul 2016 12:31:08 +0000 (14:31 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: drop select of libX11 and libXext, since the libvdpau package
already selects them.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/Config.in
package/kodi/kodi.mk

index 9a5baa8b3774652e3b98b70405ba97285e278bcc..afb834ecd7602e962fd15ba8c011a75868f21df7 100644 (file)
@@ -236,6 +236,16 @@ config BR2_PACKAGE_KODI_LIBVA
        help
          Enable libva support.
 
+config BR2_PACKAGE_KODI_LIBVDPAU
+       bool "vdpau"
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_LIBVDPAU
+       help
+         Enable libvdpau support.
+
+comment "libvdpau support needs X.org"
+       depends on !BR2_PACKAGE_XORG7
+
 config BR2_PACKAGE_KODI_UPNP
        bool "upnp"
        help
index e2919470212ec160800c69149a72f8553d3efe05..9f21bf2988ac63dcbfdb63e3f5363a9a7a1fc94e 100644 (file)
@@ -74,7 +74,6 @@ KODI_CONF_OPTS +=  \
        --disable-joystick \
        --disable-openmax \
        --disable-pulse \
-       --disable-vdpau \
        --disable-vtbdecoder \
        --enable-optimizations
 
@@ -243,6 +242,13 @@ else
 KODI_CONF_OPTS += --disable-vaapi
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_LIBVDPAU),y)
+KODI_DEPENDENCIES += libvdpau
+KODI_CONF_OPTS += --enable-vdpau
+else
+KODI_CONF_OPTS += --disable-vdpau
+endif
+
 ifeq ($(BR2_PACKAGE_KODI_UPNP),y)
 KODI_CONF_OPTS += --enable-upnp
 else