package/skeleton: don't handle merged /usr for custom skeleton
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 10 Nov 2015 21:36:29 +0000 (22:36 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 10 Nov 2015 22:47:14 +0000 (23:47 +0100)
In case the user wants to use a custom skeleton, we should not try to
handle the symlinks (resp. mkdir) to handle merged (resp. split) /usr.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/skeleton/skeleton.mk

index 11a609b01bbd128f4fd41fc791bdbe93ef91688c..38391def82c701d529b7ae7efd9ce93edfeadb51 100644 (file)
@@ -15,9 +15,9 @@ SKELETON_ADD_TOOLCHAIN_DEPENDENCY = NO
 
 ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
 SKELETON_PATH = $(call qstrip,$(BR2_ROOTFS_SKELETON_CUSTOM_PATH))
-else
+else # ! custom skeleton
+
 SKELETON_PATH = system/skeleton
-endif
 
 ifeq ($(BR2_ROOTFS_MERGED_USR),y)
 define SKELETON_USR_SYMLINKS_OR_DIRS
@@ -33,6 +33,8 @@ define SKELETON_USR_SYMLINKS_OR_DIRS
 endef
 endif
 
+endif # ! custom skeleton
+
 define SKELETON_INSTALL_TARGET_CMDS
        rsync -a --ignore-times $(SYNC_VCS_EXCLUSIONS) \
                --chmod=u=rwX,go=rX --exclude .empty --exclude '*~' \