Change --disable-shared to --enable-shared so libstdc++ will
authorEric Andersen <andersen@codepoet.org>
Thu, 9 Jan 2003 18:24:17 +0000 (18:24 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 9 Jan 2003 18:24:17 +0000 (18:24 -0000)
build shared libs.

make/gcc_target.mk
make/uclibc_toolchain.mk

index f02b7b92f87a2033b7d8bfe833019b01e98af841..a3ed649b70e04e46d01ffbc58aa1d1cccb7705c4 100644 (file)
@@ -67,8 +67,7 @@ $(BINUTILS_DIR2)/.configured:
                --mandir=/usr/man \
                --infodir=/usr/info \
                --with-gxx-include-dir=/usr/include/c++ \
-               --disable-shared $(MULTILIB) \
-               --enable-targets=$(GNU_TARGET_NAME) );
+               --disable-shared $(MULTILIB) );
        touch $(BINUTILS_DIR2)/.configured
 
 $(BINUTILS_DIR2)/binutils/objdump: $(BINUTILS_DIR2)/.configured
@@ -183,7 +182,7 @@ $(GCC_BUILD_DIR3)/.configured: $(GCC_BUILD_DIR3)/.gcc_build_hacks
                --localstatedir=/var \
                --mandir=/usr/man \
                --infodir=/usr/info \
-               --disable-shared $(MULTILIB) \
+               --enable-shared $(MULTILIB) \
                --enable-target-optspace --disable-nls --with-gnu-ld \
                --enable-languages=$(TARGET_LANGUAGES) --disable-__cxa_atexit );
        touch $(GCC_BUILD_DIR3)/.configured
index 7e37cf387a9a3943ce4187cced06d4622fac27e4..fc0f83f7c4ebf611bcfd61624fcdd410b92fbe3c 100644 (file)
@@ -370,7 +370,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.g++_build_hacks
                --with-local-prefix=$(STAGING_DIR)/usr/local \
                --oldincludedir=$(STAGING_DIR)/usr/include $(MULTILIB) \
                --enable-target-optspace --disable-nls --with-gnu-ld \
-               --disable-shared --enable-languages=$(TARGET_LANGUAGES) --disable-__cxa_atexit \
+               --enable-shared --enable-languages=$(TARGET_LANGUAGES) --disable-__cxa_atexit \
                --program-prefix=$(ARCH)-uclibc-);
        touch $(GCC_BUILD_DIR2)/.configured