package/apr: Fix detection of rlimit and large file support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 5 Oct 2014 17:38:49 +0000 (19:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Oct 2014 21:17:19 +0000 (22:17 +0100)
Snippets from configure log:

before:
checking whether to enable -D_LARGEFILE64_SOURCE... no
...
checking struct rlimit... no

after
checking whether to enable -D_LARGEFILE64_SOURCE... (cached) yes
...
checking struct rlimit... (cached) yes

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/apr/apr.mk

index 1a4c0e261bdfe0b0e04a967f4730ce5a4c9d8deb..dfaf2130aa3a2cdd181b676849b28361e65c118a 100644 (file)
@@ -16,6 +16,7 @@ APR_CONF_ENV = \
        apr_cv_mutex_robust_shared=no \
        apr_cv_tcp_nodelay_with_cork=yes \
        ac_cv_sizeof_struct_iovec=8 \
+       ac_cv_struct_rlimit=yes \
        apr_cv_mutex_recursive=yes
 APR_CONFIG_SCRIPTS = apr-1-config
 
@@ -24,6 +25,11 @@ ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
 APR_CONF_ENV += apr_cv_pthreads_lib="-lpthread"
 endif
 
+# Fix lfs detection when cross compiling
+ifeq ($(BR2_LARGEFILE),y)
+APR_CONF_ENV += apr_cv_use_lfs64=yes
+endif
+
 define APR_CLEANUP_UNNEEDED_FILES
        $(RM) -rf $(TARGET_DIR)/usr/build-1/
 endef