package/uftp: fix compilation with openssl
authorVadim Kochan <vadim4j@gmail.com>
Mon, 25 Mar 2019 23:42:37 +0000 (01:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 26 Mar 2019 11:57:52 +0000 (12:57 +0100)
Build fails with -lssl but succeeds with -lcrypto, also thats how it is
linked by default in 'makefile'.

Fixes:

  http://autobuild.buildroot.net/results/01a455ddcbc16cd2111352d22bf6603842df4ab2

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/uftp/uftp.mk

index abdb0a4def098aef82193f72617e0ef57da0a0cc..edf22cf5ce3798b2851de712798383d6ddb7a6c7 100644 (file)
@@ -11,7 +11,7 @@ UFTP_LICENSE_FILES = LICENSE.txt
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 UFTP_DEPENDENCIES += host-pkgconf openssl
-UFTP_MAKE_OPTS += CRYPT_LIB="`$(PKG_CONFIG_HOST_BINARY) --libs libssl`"
+UFTP_MAKE_OPTS += CRYPT_LIB="`$(PKG_CONFIG_HOST_BINARY) --libs libcrypto`"
 else
 UFTP_MAKE_OPTS += NO_ENCRYPTION=1
 endif