For GCC 4.2 snapshots, we need to get the actual version from the BASE-VER file so...
author"Steven J. Hill" <sjhill@realitydiluted.com>
Sat, 2 Dec 2006 05:15:27 +0000 (05:15 -0000)
committer"Steven J. Hill" <sjhill@realitydiluted.com>
Sat, 2 Dec 2006 05:15:27 +0000 (05:15 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk

index 31c5d4b5fcdd23a8ecc389ad23d7024fd59186e6..00471d71e62b59139bc2f7ebb6305a730bf80530 100644 (file)
@@ -335,9 +335,14 @@ endif
 ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
 endif
-ifeq ($(findstring 4.2.,$(GCC_VERSION)),4.2.)
+ifeq ($(findstring 4.2,$(GCC_VERSION)),4.2)
+ifneq ($(GCC_SNAP_DATE),)
+REAL_GCC_VERSION:=`cat ${GCC_DIR}/gcc/BASE-VER`
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(REAL_GCC_VERSION)
+else
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
 endif
+endif
 
 $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
        PATH=$(TARGET_PATH) \