linux.mk: enable options for ktap
authorAnders Darander <anders@chargestorm.se>
Mon, 16 Dec 2013 10:53:20 +0000 (11:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 16 Dec 2013 21:09:40 +0000 (22:09 +0100)
Certain tracing related options are required to be able to build ktapvm.ko, enable those.

Enable CONFIG_FUNTCTION_TRACER as otherwise, CONFIG_EVENT_TRACING won't stick. (Some
tracer needs to be enabled for this).

[Peter: add a note to ktap Config.in explaining this is done]
Signed-off-by: Anders Darander <anders@chargestorm.se>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk
package/ktap/Config.in

index 33931e53fc0a44e131fcc6f4f4cc76169d2b46ad..5af167ddca610bf4926a51e74cbe1376687b3a3e 100644 (file)
@@ -184,6 +184,11 @@ define LINUX_CONFIGURE_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config))
        $(if $(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),
                $(call KCONFIG_SET_OPT,CONFIG_UEVENT_HELPER_PATH,\"/sbin/mdev\",$(@D)/.config))
+       $(if $(BR2_PACKAGE_KTAP),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_DEBUG_FS,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_EVENT_TRACING,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_PERF_EVENTS,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_FUNCTION_TRACER,$(@D)/.config))
        $(if $(BR2_PACKAGE_SYSTEMD),
                $(call KCONFIG_ENABLE_OPT,CONFIG_CGROUPS,$(@D)/.config))
        $(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
index ba6b42b1bfecdb21c821398b50542880c934dba8..7f40ce2c6b60ed34ddfce5caab6a05bbb4b74dc1 100644 (file)
@@ -16,6 +16,8 @@ config BR2_PACKAGE_KTAP
          Your kernel must have CONFIG_EVENT_TRACING,
          CONFIG_PERF_EVENTS, and CONFIG_DEBUG_FS enabled to compile.
 
+         Buildroot automatically enables these in the kernel configuration.
+
          http://www.ktap.org
 
 comment "ktap needs a Linux kernel to be built"