dbus: disable bundled initscript
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Sat, 16 Jul 2016 14:32:12 +0000 (11:32 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 16 Jul 2016 14:40:11 +0000 (16:40 +0200)
Otherwise it will install $(TARGET_DIR)/etc/rc.d/init.d/messagebus when
building on a redhat/fedora host.
Regardless of that we provide our own initscript.

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dbus/dbus.mk

index 11c3d4e996cce3c9c76a5919865d1d9ac5994287..60645012109a8fd9121ba8dafc53416305d98758 100644 (file)
@@ -32,7 +32,8 @@ DBUS_CONF_OPTS = \
        --disable-dnotify \
        --with-xml=expat \
        --with-system-socket=/var/run/dbus/system_bus_socket \
-       --with-system-pid-file=/var/run/messagebus.pid
+       --with-system-pid-file=/var/run/messagebus.pid \
+       --with-init-scripts=none
 
 ifeq ($(BR2_STATIC_LIBS),y)
 DBUS_CONF_OPTS += LIBS='-pthread'