erlang-p1-xmpp: Bump to version 1.1.16
authorJohan Oudinet <johan.oudinet@gmail.com>
Tue, 16 Jan 2018 14:06:41 +0000 (15:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 17 Jan 2018 21:32:55 +0000 (22:32 +0100)
This packages now depends also on erlang-p1-utils.
Adapt the patch that removes rebar dependencies to version changes.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/erlang-p1-xmpp/0002-remove-dependencies-from-rebar-config.patch
package/erlang-p1-xmpp/Config.in
package/erlang-p1-xmpp/erlang-p1-xmpp.hash
package/erlang-p1-xmpp/erlang-p1-xmpp.mk

index fa5c269c22da919c5445f3b847096919fd2cbbc1..fed44f626db7fcdac36356aa97569f84788974a8 100644 (file)
@@ -4,15 +4,16 @@ by rebar at build time.
 Signed-off-by: Christophe Romain <cromain@process-one.net>
 
 diff --git a/rebar.config b/rebar.config
-index 79494b7..8d769f1 100644
---- a/rebar.config
-+++ b/rebar.config
-@@ -24,9 +24,6 @@
-           {i, "../fast_xml/include"},
-           {i, "deps/fast_xml/include"}]}.
+--- a/rebar.config     2017-11-30 14:24:52.348695123 +0100
++++ b/rebar.config     2017-11-30 14:35:11.816407195 +0100
+@@ -29,10 +29,6 @@
 
--{deps, [{fast_xml, ".*", {git, "https://github.com/processone/fast_xml", {tag, "1.1.22"}}},
--      {stringprep, ".*", {git, "https://github.com/processone/stringprep", {tag, "1.0.8"}}}]}.
+ {port_specs, [{"priv/lib/jid.so", ["c_src/jid.c"]}]}.
+
+-{deps, [{fast_xml, ".*", {git, "https://github.com/processone/fast_xml", {tag, "1.1.25"}}},
+-        {stringprep, ".*", {git, "https://github.com/processone/stringprep", {tag, "1.0.10"}}},
+-        {p1_utils, ".*", {git, "https://github.com/processone/p1_utils", {tag, "1.0.10"}}}]}.
 -
+ {clean_files, ["c_src/jid.gcda", "c_src/jid.gcno"]}.
+
  {cover_enabled, true}.
- {cover_export_enabled, true}.
index c7a68bc80028a41f303123d9cecb28557a290389..9b33e0c609a5954647c9e45b3dd1b53d72e60a31 100644 (file)
@@ -6,6 +6,7 @@ config BR2_PACKAGE_ERLANG_P1_XMPP
        depends on BR2_INSTALL_LIBSTDCPP # erlang-p1-stringprep
        select BR2_PACKAGE_ERLANG_P1_XML
        select BR2_PACKAGE_ERLANG_P1_STRINGPREP
+       select BR2_PACKAGE_ERLANG_P1_UTILS
        help
          XMPP library for Erlang.
 
index f245c843e841acbe07c0103c0f283a2c14613b59..d3d2dafb9ecd775e035fa7047f713799803b14f8 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 e7b5db5ab6204f5bc6ebf91a183ebeae2b43ca6372dd2506599a8e8168a99c50 erlang-p1-xmpp-1.1.9.tar.gz
+sha256 558e8d8734052bdbe679cf10165a63944c208940ab84be78c97ba661dfcf3cb2 erlang-p1-xmpp-1.1.16.tar.gz
index 149d8bc5c759e41e575b1134b7613bd02f0f05dc..096876ca347130b40fe04845b03f5bf1c0a4bf9b 100644 (file)
@@ -4,13 +4,13 @@
 #
 ################################################################################
 
-ERLANG_P1_XMPP_VERSION = 1.1.9
+ERLANG_P1_XMPP_VERSION = 1.1.16
 ERLANG_P1_XMPP_SITE = $(call github,processone,xmpp,$(ERLANG_P1_XMPP_VERSION))
 ERLANG_P1_XMPP_LICENSE = Apache-2.0
 ERLANG_P1_XMPP_LICENSE_FILES = LICENSE.txt
 ERLANG_P1_XMPP_INSTALL_STAGING = YES
 ERLANG_P1_XMPP_DEPENDENCIES = erlang-p1-xml erlang-p1-stringprep \
-       host-erlang-p1-xml
+       erlang-p1-utils host-erlang-p1-xml
 
 $(eval $(rebar-package))
 $(eval $(host-rebar-package))