package/keepalived: add optional libnftnl dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 27 Mar 2019 18:12:48 +0000 (19:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 27 Mar 2019 19:10:50 +0000 (20:10 +0100)
nftables support has been added since version 2.0.11 and
https://github.com/acassen/keepalived/commit/aa12175ea638912a7789e832634d7ccf80fdf48d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/keepalived/keepalived.mk

index fcdb43ce1307195ad0f8ed2bb14cf59629e6a185..15a1b0e9f4ad0ebd043152cfb3c8c41efd562fc9 100644 (file)
@@ -46,4 +46,11 @@ else
 KEEPALIVED_CONF_OPTS += --disable-libiptc
 endif
 
+ifeq ($(BR2_PACKAGE_LIBNFTNL),y)
+KEEPALIVED_DEPENDENCIES += libnftnl
+KEEPALIVED_CONF_OPTS += --enable-nftables
+else
+KEEPALIVED_CONF_OPTS += --disable-nftables
+endif
+
 $(eval $(autotools-package))