buildroot: add libart package
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 11 Apr 2008 11:31:40 +0000 (11:31 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 11 Apr 2008 11:31:40 +0000 (11:31 -0000)
package/Config.in
package/libart/Config.in [new file with mode: 0644]
package/libart/libart-art-config-cross.patch [new file with mode: 0644]
package/libart/libart.mk [new file with mode: 0644]

index 9f45f7359f0f8d604d096f0234797bb9d8519c71..2d725e06e515bef4e7fb9e168671ed7363d1e379 100644 (file)
@@ -318,6 +318,7 @@ source "package/directfb/Config.in"
 source "package/fusion/Config.in"
 source "package/imagemagick/Config.in"
 source "package/jpeg/Config.in"
+source "package/libart/Config.in"
 source "package/libpng/Config.in"
 source "package/libungif/Config.in"
 source "package/sdl/Config.in"
diff --git a/package/libart/Config.in b/package/libart/Config.in
new file mode 100644 (file)
index 0000000..415be09
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_LIBART
+       bool "libart"
+       default n
+       help
+         Libart is a library for high-performance 2D graphics. It
+         supports a very powerful imaging model, basically the same
+         as SVG and the Java 2D API. It includes all PostScript
+         imaging operations, and adds antialiasing and
+         alpha-transparency. It is also highly tuned for incremental
+         rendering. It contains data structures and algorithms suited
+         to rapid, precise computation of Region of Interest, and a
+         two-phase rendering pipeline optimized for interactive
+         display.
+
+         http://www.levien.com/libart/
diff --git a/package/libart/libart-art-config-cross.patch b/package/libart/libart-art-config-cross.patch
new file mode 100644 (file)
index 0000000..4cf7680
--- /dev/null
@@ -0,0 +1,34 @@
+diff -urpN libart_lgpl-2.3.20.orig/art_config.h libart_lgpl-2.3.20/art_config.h
+--- libart_lgpl-2.3.20.orig/art_config.h       2008-04-11 10:50:04.000000000 +0200
++++ libart_lgpl-2.3.20/art_config.h    2008-04-11 10:51:32.000000000 +0200
+@@ -1,9 +1,15 @@
+ /* Automatically generated by gen_art_config.c */
++#include <limits.h>
++
+ #define ART_SIZEOF_CHAR 1
+ #define ART_SIZEOF_SHORT 2
+ #define ART_SIZEOF_INT 4
++#if LONG_MAX == 2147483647L
+ #define ART_SIZEOF_LONG 4
++#else
++#define ART_SIZEOF_LONG 8
++#endif
+ typedef unsigned char art_u8;
+ typedef unsigned short art_u16;
+diff -urpN libart_lgpl-2.3.20.orig/Makefile.am libart_lgpl-2.3.20/Makefile.am
+--- libart_lgpl-2.3.20.orig/Makefile.am        2008-04-11 10:50:04.000000000 +0200
++++ libart_lgpl-2.3.20/Makefile.am     2008-04-11 10:50:31.000000000 +0200
+@@ -3,11 +3,6 @@ noinst_PROGRAMS = testart testuta gen_ar
+ bin_SCRIPTS = \
+       libart2-config
+-BUILT_SOURCES = art_config.h
+-
+-art_config.h: gen_art_config$(EXEEXT)
+-      ./gen_art_config > art_config.h
+-
+ EXTRA_DIST =                  \
+       libart.def              \
+       libart-config.in        \
diff --git a/package/libart/libart.mk b/package/libart/libart.mk
new file mode 100644 (file)
index 0000000..1857768
--- /dev/null
@@ -0,0 +1,20 @@
+#############################################################
+#
+# libart
+#
+#############################################################
+
+LIBART_VERSION = 2.3.20
+LIBART_SOURCE = libart_lgpl-$(LIBART_VERSION).tar.gz
+LIBART_SITE = http://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3/
+LIBART_AUTORECONF = YES
+LIBART_STAGING = YES
+LIBART_TARGET = YES
+
+LIBART_CONF_OPT = --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) --build=$(GNU_HOST_NAME) \
+               --prefix=/usr --sysconfdir=/etc
+
+LIBART_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,libart))