package/pkg-rebar.mk: fix remove-rebar-config-dependencies
authorJohan Oudinet <johan.oudinet@gmail.com>
Wed, 5 Dec 2018 16:06:16 +0000 (17:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 9 Dec 2018 16:24:14 +0000 (17:24 +0100)
Handle the case where there is only one dependency described in
rebar.config, so when the line starts by '{deps' and ends by '}.'.
Before it was deleting this line but also all next lines until finding
a line that ends by '}.'.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-rebar.mk

index b6b095929c127cd646d130fc618238b4399e28de..838e7681deac07007eefaf1e27cd10dd51eea3f2 100644 (file)
@@ -96,7 +96,8 @@ endef
 
 # Remove the "deps" statement from a rebar.config file
 define remove-rebar-config-dependencies
-       $(SED) '/^{deps/,/}\.$$/d' $($(PKG)_DIR)/rebar.config
+       $(SED) '/^{deps.*}\.$$/d' -e '/^{deps/,/}\.$$/d' \
+               $($(PKG)_DIR)/rebar.config
 endef