toolchain: move Stack Protection Support option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Dec 2010 16:27:42 +0000 (17:27 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 13 Dec 2010 21:06:15 +0000 (22:06 +0100)
The BR2_USE_SSP option is only used inside the uClibc build, so only
meaningful for Buildroot internal toolchains. Therefore, the option is
moved to the right location so that it isn't visible when working with
external toolchains.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-buildroot/Config.in.2
toolchain/toolchain-common.in
toolchain/uClibc/uclibc.mk

index cf426ee324d253f3cb60989823b1d5b3ce63c3f0..f1b0a7c58c4203c4803f564e3c4cb803c20c8514 100644 (file)
@@ -67,6 +67,15 @@ comment "C++ support broken in uClibc 0.9.31 with locale enabled with gcc 4.2"
                    BR2_TOOLCHAIN_BUILDROOT_LOCALE    && \
                    BR2_UCLIBC_VERSION_0_9_31
 
+config BR2_TOOLCHAIN_BUILDROOT_USE_SSP
+       bool "Enable stack protection support"
+       help
+         Enable stack smashing protection support using GCCs
+         -fstack-protector[-all] option.
+
+         See http://www.linuxfromscratch.org/hints/downloads/files/ssp.txt
+         for details.
+
 source "toolchain/elf2flt/Config.in"
 source "toolchain/mklibs/Config.in"
 source "toolchain/sstrip/Config.in"
index 2c54acdaeac56a1472d0ab1398f809768e10941d..5502ab4ff7cd437be6ff2dc487274d3dac28d11c 100644 (file)
@@ -76,15 +76,6 @@ config BR2_SOFT_FLOAT
          functions, then everything will need to be compiled with soft
          floating point support (-msoft-float).
 
-config BR2_USE_SSP
-       bool "Enable stack protection support"
-       help
-         Enable stack smashing protection support using GCCs
-         -fstack-protector[-all] option.
-
-         See http://www.linuxfromscratch.org/hints/downloads/files/ssp.txt
-         for details.
-
 choice
        prompt "Thread library implementation"
        default BR2_PTHREADS_OLD
index 1ed40cc6735d1d7c59c9e03353a2a065cea47393..e05e16c4320ae1f3508921012a0e6792c89b56db 100644 (file)
@@ -271,7 +271,7 @@ else
                -e 's,.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=y\nHAS_FPU=y\nUCLIBC_HAS_FLOATS=y\n,g' \
                $(UCLIBC_DIR)/.oldconfig
 endif
-ifeq ($(BR2_USE_SSP),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT_USE_SSP),y)
        $(SED) 's,^.*UCLIBC_HAS_SSP[^_].*,UCLIBC_HAS_SSP=y,g' $(UCLIBC_DIR)/.oldconfig
 else
        $(SED) 's,^.*UCLIBC_HAS_SSP[^_].*,UCLIBC_HAS_SSP=n,g' $(UCLIBC_DIR)/.oldconfig