linux: install dtc binary as linux-dtc
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 18:12:41 +0000 (20:12 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 18:17:35 +0000 (20:17 +0200)
So it doesn't conflict with host-dtc. The Linux kernel version may be a
patched version supporting E.G. overlays.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index 231957628a41f2c5e02c35d319fe9e085342c572..c98459f330a5f781467d4d5d651f43be010cfa65 100644 (file)
@@ -294,7 +294,7 @@ endif
 define LINUX_INSTALL_HOST_TOOLS
        # Installing dtc (device tree compiler) as host tool, if selected
        if grep -q "CONFIG_DTC=y" $(@D)/.config; then   \
-               $(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/usr/bin/dtc ;   \
+               $(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/usr/bin/linux-dtc ;     \
        fi
 endef