e2fsprogs: fix missing OPTS
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Mon, 12 Dec 2016 09:19:38 +0000 (10:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 12 Dec 2016 09:57:20 +0000 (10:57 +0100)
With the commit 64544178f180f03cedd8fe403d3718406d909c88 many packages
broke because they could not find the ext2fs.pc file.

This is perfectly normal, as the DESTDIR and the install target were not
passed anymore to make.

[Peter: remove redundant E2FSPROGS_INSTALL_STAGING_OPTS]
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/e2fsprogs/e2fsprogs.mk

index 48bb9ec38f9624fe396463de3905b2218048060c..0253510bf73e714d75309a6ec9bc9764714149d4 100644 (file)
@@ -10,7 +10,6 @@ E2FSPROGS_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/people/tytso/e2fsprogs/v$(E2F
 E2FSPROGS_LICENSE = GPLv2, libuuid BSD-3c, libss and libet MIT-like with advertising clause
 E2FSPROGS_LICENSE_FILES = NOTICE lib/uuid/COPYING lib/ss/mit-sipb-copyright.h lib/et/internal.h
 E2FSPROGS_INSTALL_STAGING = YES
-E2FSPROGS_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-libs
 E2FSPROGS_DEPENDENCIES = host-pkgconf util-linux
 # we don't have a host-util-linux
 HOST_E2FSPROGS_DEPENDENCIES = host-pkgconf
@@ -64,8 +63,14 @@ E2FSPROGS_CONF_ENV += LIBS=-lintl
 endif
 
 E2FSPROGS_MAKE_OPTS = LDCONFIG=true
-E2FSPROGS_INSTALL_STAGING_OPTS = LDCONFIG=true
-E2FSPROGS_INSTALL_TARGET_OPTS = LDCONFIG=true
+E2FSPROGS_INSTALL_STAGING_OPTS = \
+       DESTDIR=$(STAGING_DIR) \
+       LDCONFIG=true \
+       install-libs
+E2FSPROGS_INSTALL_TARGET_OPTS = \
+       DESTDIR=$(TARGET_DIR) \
+       LDCONFIG=true \
+       install
 
 define HOST_E2FSPROGS_INSTALL_CMDS
        $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install install-libs