boot/uboot: needs make >= 4.0
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 3 Feb 2020 20:20:20 +0000 (21:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Feb 2020 20:29:56 +0000 (21:29 +0100)
Starting with 2020.01, uboot started using the 'undefine' make
directive, which was only introduced with make 4.0.

In the general case, we do not have a way to know if the uboot
selected by the user is older or later than 2020.01, so we have
no way to know before hand if make >= 4.0 is needed or not. As
such, we have no other option than to always require it.

So, use the existing $(BR2_MAKE_HOST_DEPENDENCY) and $(BR2_MAKE),
both of each will ensure that we do use a make that is at least 4.0.

Reported-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/uboot/uboot.mk

index a4879bb8b26ea06679f2d82eb1ba81a118fabf7f..1f444351d70eec8780c6f42865a07de2cd5e7582 100644 (file)
@@ -12,6 +12,9 @@ UBOOT_LICENSE_FILES = Licenses/gpl-2.0.txt
 
 UBOOT_INSTALL_IMAGES = YES
 
+# u-boot 2020.01+ needs make 4.0+
+UBOOT_DEPENDENCIES = $(BR2_MAKE_HOST_DEPENDENCY)
+
 ifeq ($(UBOOT_VERSION),custom)
 # Handle custom U-Boot tarballs as specified by the configuration
 UBOOT_TARBALL = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION))
@@ -242,7 +245,7 @@ UBOOT_POST_PATCH_HOOKS += UBOOT_FIXUP_LIBFDT_INCLUDE
 ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY),y)
 define UBOOT_CONFIGURE_CMDS
        $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
+               $(BR2_MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
                $(UBOOT_BOARD_NAME)_config
 endef
 else ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG),y)
@@ -279,7 +282,7 @@ define UBOOT_BUILD_CMDS
                cp -f $(UBOOT_CUSTOM_DTS_PATH) $(@D)/arch/$(UBOOT_ARCH)/dts/
        )
        $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
+               $(BR2_MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
                $(UBOOT_MAKE_TARGET)
        $(if $(BR2_TARGET_UBOOT_FORMAT_SD),
                $(@D)/tools/mxsboot sd $(@D)/u-boot.sb $(@D)/u-boot.sd)