boot/ts4800-mrboot: remove package
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 29 Aug 2019 12:00:46 +0000 (14:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 1 Sep 2019 09:36:32 +0000 (11:36 +0200)
Since the ts4800_defconfig has been removed, the ts4800-mrboot package
is no longer useful, therefore we drop it.

Cc: Patrick Keroulas <patrick.keroulas@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
boot/Config.in
boot/ts4800-mbrboot/Config.in [deleted file]
boot/ts4800-mbrboot/ts4800-mbrboot.hash [deleted file]
boot/ts4800-mbrboot/ts4800-mbrboot.mk [deleted file]

index 190b98f5a5a1480dcd3701c1c48eb9badce96c4b..83dce8b3c8e54242927af6afffbd190ba9e8b0de 100644 (file)
@@ -146,6 +146,14 @@ endif
 
 comment "Legacy options removed in 2019.08"
 
+config BR2_TARGET_TS4800_MBRBOOT
+       bool "ts4800-mbrboot package was removed"
+       select BR2_LEGACY
+       help
+         The defconfig for the TS4800 platform has been removed, so
+         the ts4800-mbrboot package, containing the boot code for
+         this specific platform has been removed as welL.
+
 config BR2_PACKAGE_LIBAMCODEC
        bool "liamcodec package was removed"
        select BR2_LEGACY
index 97bd3de6e950e67210e55071ca08bd569b888c53..ac1a997f00fd533118f31ce1cb0fb68dc20b6fa2 100644 (file)
@@ -19,7 +19,6 @@ source "boot/riscv-pk/Config.in"
 source "boot/s500-bootloader/Config.in"
 source "boot/shim/Config.in"
 source "boot/syslinux/Config.in"
-source "boot/ts4800-mbrboot/Config.in"
 source "boot/uboot/Config.in"
 source "boot/vexpress-firmware/Config.in"
 
diff --git a/boot/ts4800-mbrboot/Config.in b/boot/ts4800-mbrboot/Config.in
deleted file mode 100644 (file)
index 7ed0b21..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_TARGET_TS4800_MBRBOOT
-       bool "ts4800-mbrboot"
-       depends on BR2_ARM_CPU_ARMV7A
-       help
-         First level bootloader for TS4800 board
-
-         https://github.com/embeddedarm/ts4800-mbrboot
diff --git a/boot/ts4800-mbrboot/ts4800-mbrboot.hash b/boot/ts4800-mbrboot/ts4800-mbrboot.hash
deleted file mode 100644 (file)
index 04e7072..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally calculated
-sha256 617c70dcf50b7ad35ed3f40666ff2a9a654a5440b522ad73662abdf9f843cee9  ts4800-mbrboot-cf8f7072ed5a4a4e48fcb9841b2e31e519ec5dca.tar.gz
diff --git a/boot/ts4800-mbrboot/ts4800-mbrboot.mk b/boot/ts4800-mbrboot/ts4800-mbrboot.mk
deleted file mode 100644 (file)
index 3dde6c6..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-################################################################################
-#
-# ts4800-mbrboot
-#
-################################################################################
-
-TS4800_MBRBOOT_VERSION = cf8f7072ed5a4a4e48fcb9841b2e31e519ec5dca
-TS4800_MBRBOOT_SITE = $(call github,embeddedarm,ts4800-mbrboot,$(TS4800_MBRBOOT_VERSION))
-TS4800_MBRBOOT_LICENSE = BSD-2-Clause
-TS4800_MBRBOOT_LICENSE_FILES = LICENSE
-TS4800_MBRBOOT_INSTALL_IMAGES = YES
-
-define TS4800_MBRBOOT_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
-endef
-
-define TS4800_MBRBOOT_INSTALL_IMAGES_CMDS
-       $(INSTALL) -D -m 0644 $(@D)/mbrboot.bin $(BINARIES_DIR)/mbrboot.bin
-endef
-
-$(eval $(generic-package))