Fixup a case where system libs could sneak into the link process
authorEric Andersen <andersen@codepoet.org>
Wed, 4 Jun 2003 21:39:44 +0000 (21:39 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 4 Jun 2003 21:39:44 +0000 (21:39 -0000)
due to collect2 making wrong assumptions.

make/uclibc_toolchain.mk

index 2341bd8d9723f9eec4783317d0cabf00b1cdfed7..663c21eb77579e8d15f4c71da1e814318679c0f3 100644 (file)
@@ -235,6 +235,13 @@ $(GCC_DIR)/.gcc_build_hacks: $(GCC_DIR)/.patched
        perl -i -p -e "s,^#define.*STANDARD_INCLUDE_DIR.*,#define STANDARD_INCLUDE_DIR \
                \"$(STAGING_DIR)/include\",;" $(GCC_DIR)/gcc/cppdefault.h;
        #
+       # Prevent system glibc libraries from being found by collect2 
+       # when it calls locatelib() and rummages about the system looking 
+       # for libraries with the correct name...
+       #
+       perl -i -p -e "s,\"/lib/,\"$(STAGING_DIR)/lib,g;" $(GCC_DIR)/gcc/collect2.c
+       perl -i -p -e "s,\"/usr/,\"$(STAGING_DIR)/usr/,g;" $(GCC_DIR)/gcc/collect2.c
+       #
        # Prevent gcc from using the unwind-dw2-fde-glibc code
        #
        perl -i -p -e "s,^#ifndef inhibit_libc,#define inhibit_libc\n\