icu: add an option to add a custom data library file
authorJohan Derycke <johanderycke@gmail.com>
Tue, 13 May 2014 16:10:18 +0000 (18:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Jul 2014 20:43:04 +0000 (22:43 +0200)
[Thomas:
 - use one single BR2_PACKAGE_ICU_CUSTOM_DATA_PATH string option
   instead of a boolean option + a string option, which always causes
   a lot of issues with random configurations that enable the boolean
   option, but do not provide a valid value for the string option.
 - enclose the definition of ICU_COPY_CUSTOM_DATA into the condition.]

Signed-off-by: Johan Derycke <johan.derycke@barco.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/icu/Config.in
package/icu/icu.mk

index 9a278942f8b1daf389cedcd3d3c794a21d95c8e5..d14f8d8e3cada2b4a2c4316287b3033c4c103abd 100644 (file)
@@ -13,6 +13,18 @@ config BR2_PACKAGE_ICU
 
          http://site.icu-project.org/
 
+if BR2_PACKAGE_ICU
+
+config BR2_PACKAGE_ICU_CUSTOM_DATA_PATH
+       string "Path to custom data library file"
+       help
+         This option allows to define the path to a custom data
+         library generated with
+         http://apps.icu-project.org/datacustom/ICUData51.html. Leave
+         empty to not use this functionality.
+
+endif
+
 comment "icu needs a toolchain w/ C++, wchar, threads"
        depends on !BR2_arc
        depends on !BR2_BINFMT_FLAT
index f93eab1476d6cd2c24c45d4798264b33dc4327f0..208229d7131d4638d89bb1a8d06301bcd07c69ac 100644 (file)
@@ -26,5 +26,12 @@ ICU_MAKE = $(MAKE1)
 ICU_SUBDIR = source
 HOST_ICU_SUBDIR = source
 
+ifneq ($(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH),)
+define ICU_COPY_CUSTOM_DATA
+       cp $(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
+endef
+ICU_POST_PATCH_HOOKS += ICU_COPY_CUSTOM_DATA
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))