qtuio: add error handling to for loop
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Dec 2014 22:05:44 +0000 (23:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Dec 2014 20:53:57 +0000 (21:53 +0100)
Also remove unneeded sub-shell usage in the build and installation
steps. It is kept for the configure step as it is actually useful, and
works fine because "|| exit 1" is outside the sub-shell.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/qtuio/qtuio.mk

index 9925f84699783679da85798abc3f462722ce4429..5fa10a76b72caad6e03146b815f19e173bde2e1b 100644 (file)
@@ -19,7 +19,7 @@ QTUIO_EXAMPLES = dials fingerpaint knobs pinchzoom
 ifeq ($(BR2_QTUIO_EXAMPLES),y)
 define QTUIO_CONFIGURE_EXAMPLES
        for example in $(QTUIO_EXAMPLES) ; do \
-               (cd $(@D)/examples/$${example} && $(TARGET_MAKE_ENV) $(QT_QMAKE)) ; \
+               (cd $(@D)/examples/$${example} && $(TARGET_MAKE_ENV) $(QT_QMAKE)) || exit 1; \
        done
 endef
 endif
@@ -32,7 +32,7 @@ endef
 ifeq ($(BR2_QTUIO_EXAMPLES),y)
 define QTUIO_BUILD_EXAMPLES
        for example in $(QTUIO_EXAMPLES) ; do \
-               ($(MAKE) -C $(@D)/examples/$${example}) ; \
+               $(MAKE) -C $(@D)/examples/$${example} || exit 1; \
        done
 endef
 endif
@@ -46,7 +46,7 @@ endef
 ifeq ($(BR2_QTUIO_EXAMPLES),y)
 define QTUIO_INSTALL_EXAMPLES
        for example in $(QTUIO_EXAMPLES) ; do \
-               ($(INSTALL) -D -m 0755 $(@D)/examples/$${example}/$${example} $(TARGET_DIR)/usr/share/qtuio/$${example}) ; \
+               $(INSTALL) -D -m 0755 $(@D)/examples/$${example}/$${example} $(TARGET_DIR)/usr/share/qtuio/$${example} || exit 1 ; \
        done
 endef
 endif