package/rauc: disable systemd for host build
authorBartosz Bilas <b.bilas@grinn-global.com>
Fri, 13 Nov 2020 15:15:58 +0000 (16:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 14 Nov 2020 13:30:19 +0000 (14:30 +0100)
Since there is not necessary to have support of systemd within the host
variant let's disable it unconditionally to solve the following errors:

/usr/bin/install -c -m 644 data/rauc.service '/usr/lib/systemd/system'
/usr/bin/install: cannot create regular file '/usr/lib/systemd/system/rauc.service': Permission denied
/usr/bin/install -c -m 644 data/de.pengutronix.rauc.conf 'no'
make[4]: *** [Makefile:1700: install-nodist_systemdunitDATA] Error 1
make[4]: *** Waiting for unfinished jobs....

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rauc/rauc.mk

index 61c50ab316a8e1737194288116a729383a9f39cc..a6c7c010953beb9d0ed3d6d3bd85189c186d6755 100644 (file)
@@ -46,7 +46,8 @@ HOST_RAUC_CONF_OPTS += \
        --disable-network \
        --disable-json \
        --disable-service \
-       --without-dbuspolicydir
+       --without-dbuspolicydir \
+       --with-systemdunitdir=no
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))