python-xlwt: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 29 Jun 2016 06:27:04 +0000 (08:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 15:31:02 +0000 (17:31 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-xlwt/Config.in [new file with mode: 0644]
package/python-xlwt/python-xlwt.hash [new file with mode: 0644]
package/python-xlwt/python-xlwt.mk [new file with mode: 0644]

index f120025cfb0ac4ba59498e515574fd6bff92fc31..e230df4eec4ec3e24766e195961cbe52f3d1a1c4 100644 (file)
@@ -788,6 +788,7 @@ menu "External python modules"
        source "package/python-wsaccel/Config.in"
        source "package/python-xlrd/Config.in"
        source "package/python-xlsxwriter/Config.in"
+       source "package/python-xlwt/Config.in"
        source "package/python-zope-interface/Config.in"
 endmenu
 endif
diff --git a/package/python-xlwt/Config.in b/package/python-xlwt/Config.in
new file mode 100644 (file)
index 0000000..a48ac6f
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_XLWT
+       bool "python-xlwt"
+       help
+         Library to create spreadsheet files compatible with MS Excel
+         97/2000/XP/2003 XLS files, on any platform, with Python 2.6,
+         2.7, 3.3+.
+
+         http://www.python-excel.org/
diff --git a/package/python-xlwt/python-xlwt.hash b/package/python-xlwt/python-xlwt.hash
new file mode 100644 (file)
index 0000000..4cacf2b
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/xlwt/json
+md5    fadf8d1be8c5f071561c4145ed5f5b89  xlwt-1.1.2.tar.gz
+# sha256 calculated by scanpypi
+sha256 aed648c17731f40f84550dd2a1aaa53569f0cbcaf5610ba895cd2632587b723c  xlwt-1.1.2.tar.gz
diff --git a/package/python-xlwt/python-xlwt.mk b/package/python-xlwt/python-xlwt.mk
new file mode 100644 (file)
index 0000000..38d5f09
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-xlwt
+#
+################################################################################
+
+PYTHON_XLWT_VERSION = 1.1.2
+PYTHON_XLWT_SOURCE = xlwt-$(PYTHON_XLWT_VERSION).tar.gz
+PYTHON_XLWT_SITE = https://pypi.python.org/packages/0b/69/644313df86e6375ec2c6b34ec8ac544b9cc7803b7d943223d32811860f3d
+PYTHON_XLWT_SETUP_TYPE = setuptools
+PYTHON_XLWT_LICENSE = BSD-3c, BSD-4c
+PYTHON_XLWT_LICENSE_FILES = docs/licenses.rst
+
+$(eval $(python-package))