projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ad501b6
)
busybox: only install S01logging if syslogd applet is enabled
author
Peter Korsgaard
<jacmet@sunsite.dk>
Mon, 4 Jul 2011 19:03:37 +0000
(21:03 +0200)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Mon, 4 Jul 2011 19:03:37 +0000
(21:03 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/busybox.mk
patch
|
blob
|
history
diff --git
a/package/busybox/busybox.mk
b/package/busybox/busybox.mk
index 4931b0744c4231d8e0697ceba8b4a19153b66a4c..509c3bb9f1147a11df8351ac1482701cc8d02b11 100644
(file)
--- a/
package/busybox/busybox.mk
+++ b/
package/busybox/busybox.mk
@@
-123,8
+123,10
@@
endef
endif
define BUSYBOX_INSTALL_LOGGING_SCRIPT
- $(INSTALL) -m 0755 -D package/busybox/S01logging \
- $(TARGET_DIR)/etc/init.d/S01logging
+ if grep -q CONFIG_SYSLOGD=y $(@D)/.config; then \
+ $(INSTALL) -m 0755 -D package/busybox/S01logging \
+ $(TARGET_DIR)/etc/init.d/S01logging; \
+ else rm -f $(TARGET_DIR)/etc/init.d/S01logging; fi
endef
# We do this here to avoid busting a modified .config in configure