tftpd: use <pkg>_INSTALL_INIT_SYSV mechanism
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:11 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 22:01:19 +0000 (23:01 +0100)
Also make sure we use a full path for the destination of the
$(INSTALL) command.

[Peter: use install -m as noted by Yann]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tftpd/tftpd.mk

index 816a25ec5160f1c7c78391b818af3921064913a1..778d45fd8585ef6049a2f4810c1afcc8ab87a0f1 100644 (file)
@@ -21,7 +21,10 @@ endif
 define TFTPD_INSTALL_TARGET_CMDS
        $(INSTALL) -D $(@D)/tftp/tftp $(TARGET_DIR)/usr/bin/tftp
        $(INSTALL) -D $(@D)/tftpd/tftpd $(TARGET_DIR)/usr/sbin/tftpd
-       $(INSTALL) -D package/tftpd/S80tftpd-hpa $(TARGET_DIR)/etc/init.d/
+endef
+
+define TFTPD_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 0755 package/tftpd/S80tftpd-hpa $(TARGET_DIR)/etc/init.d/S80tftpd-hpa
 endef
 
 $(eval $(autotools-package))