package/usbguard: fix build with libgcrypt
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 23 Jun 2021 16:59:24 +0000 (18:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Jun 2021 13:06:42 +0000 (15:06 +0200)
Building with libgcrypt fails since the addition of the package in
commit fbff7d7289cc95db991184f890f4ca1fcf8a101e:

checking for sparc64-buildroot-linux-gnu-libgcrypt-config... no
checking for libgcrypt-config... no
checking for LIBGCRYPT - version >= 1.5.0... no
configure: error: The selected crypto backend library is not available.

Fix this build failure by helping usbguard to find libgcrypt-config

Fixes:
 - http://autobuild.buildroot.org/results/4c19e50a2a5308cb31a62f1b4b538a30353022bb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/usbguard/usbguard.mk

index f3bd7c57ac86862cfd9ebc6954c2eb7b96907eff..53d103346e75b668d0249cd70c5c7ceacda95169 100644 (file)
@@ -24,6 +24,8 @@ USBGUARD_DEPENDENCIES += libopenssl
 endif
 
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+USBGUARD_CONF_ENV += \
+       ac_cv_path_LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
 USBGUARD_CONF_OPTS += --with-crypto-library=gcrypt
 USBGUARD_DEPENDENCIES += libgcrypt
 endif