package/ljsyscall: fix build with aarch64
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 13 Dec 2019 22:09:11 +0000 (23:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 14 Dec 2019 14:26:37 +0000 (15:26 +0100)
luajit supports aarch64 since commit
2ca0accc21a090874ac6e97670b47153a1f0a0b5

However this raise a build failure with ljsyscall because aarch64
directory does not exist so use arm64 instead

Fixes:
 - http://autobuild.buildroot.org/results/3a0bd14349b3cab3e09d0b8b24ddab66dfab91ff

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ljsyscall/ljsyscall.mk

index 30b5cde22a960eda949672d9d0f568f443f27809..12dfbcb4ae9d5052bac43a744d86193200822756 100644 (file)
@@ -18,6 +18,8 @@ else ifeq ($(BR2_powerpc),y)
 LJSYSCALL_ARCH = ppc
 else ifeq ($(BR2_arm)$(BR2_armeb),y)
 LJSYSCALL_ARCH = arm
+else ifeq ($(BR2_aarch64),y)
+LJSYSCALL_ARCH = arm64
 else ifeq ($(BR2_mips)$(BR2_mipsel),y)
 LJSYSCALL_ARCH = mips
 else