infozip: Add a host variant
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tue, 1 Apr 2014 22:24:38 +0000 (00:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 3 Apr 2014 18:15:05 +0000 (20:15 +0200)
Adding a host variant to the package infozip. It will be used by XBMC.

[Thomas: use HOST_CONFIGURE_OPTS instead of TARGET_CONFIGURE_OPTS in
the host installation step.]

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/infozip/infozip.mk

index 8e5122405c311fb5254cc937afc8501af5c090a8..42cd1db302f39101529bb528e4630bd0c1e86aa1 100644 (file)
@@ -26,4 +26,17 @@ define INFOZIP_INSTALL_TARGET_CMDS
                prefix=$(TARGET_DIR)/usr
 endef
 
+define HOST_INFOZIP_BUILD_CMDS
+       $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D) \
+               CFLAGS="$(HOST_CFLAGS) -I. -DUNIX" \
+               AS="$(HOST_CC) -c" \
+               -f unix/Makefile generic
+endef
+
+define HOST_INFOZIP_INSTALL_CMDS
+       $(MAKE) $(HOST_CONFIGURE_OPTS) -C $(@D) -f unix/Makefile install \
+               prefix=$(HOST_DIR)/usr
+endef
+
 $(eval $(generic-package))
+$(eval $(host-generic-package))