libshairplay: new package
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Sun, 19 Jan 2014 21:04:02 +0000 (22:04 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 22 Jan 2014 22:47:57 +0000 (23:47 +0100)
libshairplay is a client library that emulates an airplay server
This package was originally found at : https://github.com/huceke/buildroot-rbp
By gimli <ebsi4711@gmail.com>

[Peter: fix whitespace, needs threads, host-pkgconf and optionally libao]
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Cc: gimli <ebsi4711@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libshairplay/Config.in [new file with mode: 0644]
package/libshairplay/libshairplay.mk [new file with mode: 0644]

index fcbf7209c4cfae9a7aa0dec13b00cbc509f446f6..3bf3434663d614517922a5d727685c0f6ed2f784 100644 (file)
@@ -682,6 +682,7 @@ source "package/libosip2/Config.in"
 source "package/libpcap/Config.in"
 source "package/librsync/Config.in"
 source "package/libsocketcan/Config.in"
+source "package/libshairplay/Config.in"
 source "package/libsoup/Config.in"
 source "package/libtirpc/Config.in"
 source "package/libtorrent/Config.in"
diff --git a/package/libshairplay/Config.in b/package/libshairplay/Config.in
new file mode 100644 (file)
index 0000000..bcdad3f
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LIBSHAIRPLAY
+       bool "libshairplay"
+       depends on BR2_INET_IPV6
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         libshairplay is a client library that emulates an airplay
+         server.
+
+         https://github.com/juhovh/shairplay
+
+comment "libshairplay needs a toolchain w/ IPv6, threads"
+       depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libshairplay/libshairplay.mk b/package/libshairplay/libshairplay.mk
new file mode 100644 (file)
index 0000000..fc397d7
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libshairplay
+#
+################################################################################
+
+LIBSHAIRPLAY_VERSION = 139d5ef55564514c31f02dd82cef91236c9ff523
+LIBSHAIRPLAY_SITE = $(call github,juhovh,shairplay,$(LIBSHAIRPLAY_VERSION))
+LIBSHAIRPLAY_INSTALL_STAGING = YES
+LIBSHAIRPLAY_AUTORECONF = YES
+LIBSHAIRPLAY_LICENSE = MIT, BSD-3c, LGPLv2.1+
+LIBSHAIRPLAY_LICENSE_FILES = LICENSE
+LIBSHAIRPLAY_DEPENDENCIES = host-pkgconf $(if $(BR2_PACKAGE_LIBAO),libao)
+
+$(eval $(autotools-package))