nettle: add new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 28 Dec 2012 10:01:08 +0000 (10:01 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Dec 2012 20:36:43 +0000 (21:36 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/nettle/Config.in [new file with mode: 0644]
package/nettle/nettle.mk [new file with mode: 0644]

index 3d556b2b9fe90e02fa2b3cba2d020ebd938ac0f3..6c82bab857914284ccfb80a12ae9eaea9ea09f71 100644 (file)
@@ -363,6 +363,7 @@ source "package/gnutls/Config.in"
 source "package/libgcrypt/Config.in"
 source "package/libgpg-error/Config.in"
 source "package/libnss/Config.in"
+source "package/nettle/Config.in"
 source "package/ocf-linux/Config.in"
 source "package/openssl/Config.in"
 source "package/polarssl/Config.in"
diff --git a/package/nettle/Config.in b/package/nettle/Config.in
new file mode 100644 (file)
index 0000000..5577621
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_NETTLE
+       bool "nettle"
+       select BR2_PACKAGE_GMP
+       help
+         Nettle is a cryptographic library that is designed to fit easily
+         in more or less any context: In crypto toolkits for object-oriented
+         languages, in applications like LSH or GNUPG, or even in kernel space
+
+         http://www.lysator.liu.se/~nisse/nettle/
diff --git a/package/nettle/nettle.mk b/package/nettle/nettle.mk
new file mode 100644 (file)
index 0000000..ef7640a
--- /dev/null
@@ -0,0 +1,12 @@
+NETTLE_VERSION = 2.5
+NETTLE_SITE = http://www.lysator.liu.se/~nisse/archive
+NETTLE_DEPENDENCIES = gmp
+NETTLE_INSTALL_STAGING = YES
+
+define NETTLE_DITCH_DEBUGGING_CFLAGS
+       $(SED) '/CFLAGS/ s/ -ggdb3//' $(@D)/configure
+endef
+
+NETTLE_POST_EXTRACT_HOOKS += NETTLE_DITCH_DEBUGGING_CFLAGS
+
+$(eval $(autotools-package))