wmctrl: new package
authorJérôme Pouiller <jezz@sysmic.org>
Thu, 2 Jan 2014 21:29:40 +0000 (22:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jan 2014 21:38:33 +0000 (22:38 +0100)
Provides command line access to almost all the features defined in
the EWMH specification. It can be used, for example, to get
information about the window manager, to get a detailed list of
desktops and managed windows, to switch and resize desktops, to
make windows full-screen, always-above or sticky, and to activate,
close, move, resize, maximize and minimize them.

[Thomas:
 - fixed license, which is GPLv2+, not GPLv2
 - fixed wrapping of the Config.in help text
 - removed Config.in comment related to MMU dependency.]

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/wmctrl/Config.in [new file with mode: 0644]
package/wmctrl/wmctrl.mk [new file with mode: 0644]

index 429b51935e5af0b9ab4a005bb6a9e0c81db567b4..73d64bf263acedc5097115ced5a61e3030aec015 100644 (file)
@@ -229,6 +229,7 @@ source "package/rdesktop/Config.in"
 source "package/sylpheed/Config.in"
 source "package/synergy/Config.in"
 source "package/torsmo/Config.in"
+source "package/wmctrl/Config.in"
 source "package/x11vnc/Config.in"
 source "package/xscreensaver/Config.in"
 source "package/xstroke/Config.in"
diff --git a/package/wmctrl/Config.in b/package/wmctrl/Config.in
new file mode 100644 (file)
index 0000000..334f47d
--- /dev/null
@@ -0,0 +1,23 @@
+config BR2_PACKAGE_WMCTRL
+       bool "wmctrl"
+       select BR2_PACKAGE_XLIB_LIBX11
+       select BR2_PACKAGE_XLIB_LIBXMU
+       select BR2_PACKAGE_LIBGLIB2
+       depends on BR2_PACKAGE_XORG7
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       help
+         Provides command line access to almost all the features
+         defined in the EWMH specification. It can be used, for
+         example, to get information about the window manager, to get
+         a detailed list of desktops and managed windows, to switch
+         and resize desktops, to make windows full-screen,
+         always-above or sticky, and to activate, close, move,
+         resize, maximize and minimize them.
+
+         http://tomas.styblo.name/wmctrl/
+
+comment "libglib2 needs a toolchain w/ wchar, threads"
+       depends on !BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/wmctrl/wmctrl.mk b/package/wmctrl/wmctrl.mk
new file mode 100644 (file)
index 0000000..a4e0d8e
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# wmctrl
+#
+################################################################################
+
+WMCTRL_VERSION = 1.07
+WMCTRL_SITE = http://tomas.styblo.name/wmctrl/dist
+WMCTRL_LICENSE = GPLv2+
+WMCTRL_LICENSE_FILES = COPYING
+
+WMCTRL_DEPENDENCIES = libglib2 xlib_libX11 xlib_libXmu
+
+$(eval $(autotools-package))