package/qextserialport: convert to qmake infra
authorAndreas Naumann <anaumann@ultratronik.de>
Mon, 9 Mar 2020 21:39:39 +0000 (22:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 9 Mar 2020 21:39:39 +0000 (22:39 +0100)
This commit converts the qextserialport to the qmake infra, which is a
straightforward conversion as it doesn't require any custom
environment option or additional hook.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qextserialport/qextserialport.mk

index ecaff21efc879df6a9dd622f64b694fb85a7e4cb..419ea669cb7e4e0af72efa4d058cfb82a592fb8d 100644 (file)
@@ -14,26 +14,4 @@ ifeq ($(BR2_STATIC_LIBS),y)
 QEXTSERIALPORT_CONF_OPTS += CONFIG+=qesp_static
 endif
 
-QEXTSERIALPORT_DEPENDENCIES = qt5base
-
-define QEXTSERIALPORT_CONFIGURE_CMDS
-       cd $(@D); $(TARGET_MAKE_ENV) $(QT5_QMAKE) $(QEXTSERIALPORT_CONF_OPTS)
-endef
-
-define QEXTSERIALPORT_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
-endef
-
-define QEXTSERIALPORT_INSTALL_STAGING_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
-endef
-
-ifeq ($(BR2_STATIC_LIBS),y)
-QEXTSERIALPORT_INSTALL_TARGET = NO
-else
-define QEXTSERIALPORT_INSTALL_TARGET_CMDS
-       cp -a $(@D)/*.so.* $(TARGET_DIR)/usr/lib
-endef
-endif
-
-$(eval $(generic-package))
+$(eval $(qmake-package))