snmppp: add option to enable logging
authorLuca Ceresoli <luca@lucaceresoli.net>
Sun, 6 Apr 2014 22:20:04 +0000 (00:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 7 Apr 2014 23:19:15 +0000 (01:19 +0200)
SNMP++ logging can be overly verbose, and according to the SNMP++
documentation, disabling logging "increases performance drastically and
minimizes memory consumption".

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/snmppp/Config.in
package/snmppp/snmppp.mk

index 5d6d749b81629d969102640b85836e58a95d3354..1d5113fbb0f1b47ea687880e019d2da41ff14632 100644 (file)
@@ -8,5 +8,16 @@ config BR2_PACKAGE_SNMPPP
 
          http://www.agentpp.com/snmp_pp3_x/snmp_pp3_x.html
 
+if BR2_PACKAGE_SNMPPP
+
+config BR2_PACKAGE_SNMPPP_LOGGING
+       bool "enable logging"
+       help
+         Enable logging output for SNMP++.
+         According to the SNMP++ documentation, disabling logging "increases
+         performance drastically and minimizes memory consumption".
+
+endif
+
 comment "snmp++ needs a toolchain w/ threads, C++"
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
index 78d7dc92cd20ee85df665078bbde4933be4fb131..3f3018d2ad5890c83db6e0dcd0bbf22488fabb39 100644 (file)
@@ -11,6 +11,7 @@ SNMPPP_DEPENDENCIES = openssl host-pkgconf
 SNMPPP_INSTALL_STAGING = YES
 # no configure script in tarball
 SNMPPP_AUTORECONF = YES
+SNMPPP_CONF_OPT = $(if $(BR2_PACKAGE_SNMPPP_LOGGING),--enable-logging,--disable-logging)
 SNMPPP_LICENSE = SNMP++
 SNMPPP_LICENSE_FILES = src/v3.cpp