package/qemu: add option to include tools
authorSam bobroff <sam.bobroff@au1.ibm.com>
Wed, 23 Nov 2016 00:16:52 +0000 (11:16 +1100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Nov 2016 14:27:44 +0000 (15:27 +0100)
Add an option to QEMU to include the "tools" (configure option:
--enable-tools) in the target. This adds a dependency on pixman, but
that's already present.

Signed-off-by: Sam Bobroff <sam.bobroff@au1.ibm.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qemu/Config.in
package/qemu/qemu.mk

index e935ef9c6173abb85878ee9affecb08405eba65d..b9c1ca181657a453e746715a09d33eeaefad7427 100644 (file)
@@ -107,4 +107,9 @@ comment "FDT support needs a toolchain w/ dynamic library"
 
 endif # BR2_PACKAGE_QEMU_HAS_EMULS
 
+config BR2_PACKAGE_QEMU_TOOLS
+       bool "Enable tools"
+       help
+         Say 'y' here to include tools packaged with QEMU (e.g. qemu-img).
+
 endif # BR2_PACKAGE_QEMU
index 45fc0fad0af1f9591c46d71f8cb074429c27adf8..bc707cf7e6e94337977ced7c68b65b660f96b32a 100644 (file)
@@ -204,6 +204,12 @@ else
 QEMU_OPTS += --disable-fdt
 endif
 
+ifeq ($(BR2_PACKAGE_QEMU_TOOLS),y)
+QEMU_OPTS += --enable-tools
+else
+QEMU_OPTS += --disable-tools
+endif
+
 # Override CPP, as it expects to be able to call it like it'd
 # call the compiler.
 define QEMU_CONFIGURE_CMDS
@@ -242,7 +248,6 @@ define QEMU_CONFIGURE_CMDS
                        --disable-strip                 \
                        --disable-seccomp               \
                        --disable-sparse                \
-                       --disable-tools                 \
                        $(QEMU_OPTS)                    \
        )
 endef