avahi: Add systemd init script
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Sat, 3 May 2014 15:35:45 +0000 (17:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 May 2014 16:38:53 +0000 (18:38 +0200)
This consists of two files:
  - avahi-daemon.service:
    It start/stop the daemon avahi, it's a copy of the S50avahi-daemon
    script.
  - avahi_tmpfiles.conf:
    This one gets installed in /usr/lib/tmpfiles.d/ to be used by
    systemd-tmpfiles which will create the correct directory structure
    with the appropriate rights.
    This is the equivalent of the S05avahi-setup.sh script.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/avahi/avahi-daemon.service [new file with mode: 0644]
package/avahi/avahi.mk
package/avahi/avahi_tmpfiles.conf [new file with mode: 0644]

diff --git a/package/avahi/avahi-daemon.service b/package/avahi/avahi-daemon.service
new file mode 100644 (file)
index 0000000..c9b7b1f
--- /dev/null
@@ -0,0 +1,15 @@
+[Unit]
+Description=Avahi daemon
+Requires=dbus.target
+After=syslog.target network.target auditd.service
+
+[Service]
+Type=oneshot
+RemainAfterExit=ye
+ExecStart=/usr/sbin/avahi-daemon -s
+ExecReload=/usr/sbin/avahi-daemon -r
+ExecStop=/usr/sbin/avahi-daemon -k
+Restart=restart-always
+
+[Install]
+WantedBy=multi-user.target
index 609b05da7c197c417f77ad4ba4ae2a2ff60da7f1..6e84564b2d4ab6c1cfe4f92c6dd28c6fbac0a0bb 100644 (file)
@@ -153,12 +153,28 @@ ifeq ($(BR2_PACKAGE_AVAHI_AUTOIPD),y)
 AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_AUTOIPD
 endif
 
-define AVAHI_INSTALL_DAEMON_INITSCRIPT
+ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
+
+define AVAHI_INSTALL_INIT_SYSTEMD
+  $(INSTALL) -D -m 644 package/avahi/avahi-daemon.service \
+    $(TARGET_DIR)/etc/systemd/system/avahi-daemon.service
+
+  mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+
+  ln -fs ../avahi-daemon.service \
+    $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/avahi-daemon.service
+
+  mkdir -p $(TARGET_DIR)/usr/lib/tmpfiles.d
+
+  $(INSTALL) -D -m 644 package/avahi/avahi_tmpfiles.conf \
+    $(TARGET_DIR)/usr/lib/tmpfiles.d/avahi.conf
+
+endef
+
+define AVAHI_INSTALL_INIT_SYSV
        $(INSTALL) -m 0755 package/avahi/S50avahi-daemon $(TARGET_DIR)/etc/init.d/
 endef
 
-ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
-AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_DAEMON_INITSCRIPT
 endif
 
 $(eval $(autotools-package))
diff --git a/package/avahi/avahi_tmpfiles.conf b/package/avahi/avahi_tmpfiles.conf
new file mode 100644 (file)
index 0000000..41eb3c6
--- /dev/null
@@ -0,0 +1 @@
+d /tmp/avahi-autopid 0755 default default