package/cereal: new package
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Mon, 23 Dec 2019 15:10:59 +0000 (16:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Dec 2019 21:46:39 +0000 (22:46 +0100)
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/cereal/Config.in [new file with mode: 0644]
package/cereal/cereal.hash [new file with mode: 0644]
package/cereal/cereal.mk [new file with mode: 0644]

index e72ec0d70a26a65e8481ab012b239834aef97473..7171052243b83074a77c86968585f645b74f9969 100644 (file)
@@ -2335,6 +2335,7 @@ F:        package/civetweb/
 
 N:     Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 F:     docs/manual/
+F:     package/cereal/
 F:     package/libtelnet/
 F:     package/opkg-utils/
 F:     package/perl-convert-asn1/
index 44e2b9fe31c9f40682e096aaf4865aa444cabfad..01bf385178cbc13417ad5114392f024ad6679c80 100644 (file)
@@ -1732,6 +1732,7 @@ menu "Other"
        source "package/c-capnproto/Config.in"
        source "package/capnproto/Config.in"
        source "package/cctz/Config.in"
+       source "package/cereal/Config.in"
        source "package/clang/Config.in"
        source "package/clapack/Config.in"
        source "package/classpath/Config.in"
diff --git a/package/cereal/Config.in b/package/cereal/Config.in
new file mode 100644 (file)
index 0000000..3ac463c
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_CEREAL
+       bool "cereal"
+       depends on BR2_USE_WCHAR
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
+       help
+         cereal is a header-only C++11 serialization library.
+         cereal takes arbitrary data types and reversibly turns them
+         into different representations, such as compact binary
+         encodings, XML or JSON. cereal was designed to be fast,
+         light-weight, and easy to extend - it has no external
+         dependencies and can be easily bundled with other code or used
+         standalone.
+
+         https://github.com/USCiLab/cereal
+
+comment "cereal needs a toolchain w/ C++, gcc >= 4.7, threads, wchar"
+       depends on !BR2_INSTALL_LIBSTDCPP  || !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_USE_WCHAR || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
diff --git a/package/cereal/cereal.hash b/package/cereal/cereal.hash
new file mode 100644 (file)
index 0000000..ddaf54e
--- /dev/null
@@ -0,0 +1,6 @@
+# Locally computed
+sha256 329ea3e3130b026c03a4acc50e168e7daff4e6e661bc6a7dfec0d77b570851d5  cereal-1.3.0.tar.gz
+sha256 18fd7618c44c9fe28b5f54cd19747df3c0472ed33e8507fea571e2acf6e72f34  LICENSE
+sha256 d9e523e8736ac0c68064c7ad312a222f285e82bf6c96a1b1c2cadaffff9fc64f  include/cereal/external/base64.hpp
+sha256 7fb69c707f0ed3a8b59b8f949f0928a9cc06d67bc15d599094693703ff70ea26  include/cereal/external/rapidjson/rapidjson.h
+sha256 794bf3b2ecf5cf0c740ac6c524d66ce6284c4b1de1f983d21a242b8abbeb9720  include/cereal/external/rapidxml/license.txt
diff --git a/package/cereal/cereal.mk b/package/cereal/cereal.mk
new file mode 100644 (file)
index 0000000..3811fdf
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# cereal
+#
+################################################################################
+
+CEREAL_VERSION = 1.3.0
+CEREAL_SITE = $(call github,USCiLab,cereal,v$(CEREAL_VERSION))
+# For licensing, see also: https://github.com/USCiLab/cereal/issues/609
+CEREAL_LICENSE = BSD-3-Clause (cereal), Zlib (base64.hpp), MIT (rapidjson), BSL-1.0 or MIT (rapidxml)
+CEREAL_LICENSE_FILES = LICENSE include/cereal/external/base64.hpp include/cereal/external/rapidjson/rapidjson.h include/cereal/external/rapidxml/license.txt
+CEREAL_INSTALL_STAGING = YES
+CEREAL_INSTALL_TARGET = NO
+CEREAL_CONF_OPTS = \
+       -DTHREAD_SAFE=ON \
+       -DJUST_INSTALL_CEREAL=ON
+
+$(eval $(cmake-package))