libpng: remove libpng*-config scripts from TARGET_DIR
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Dec 2010 17:23:11 +0000 (18:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 7 Mar 2011 21:22:31 +0000 (22:22 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libpng/libpng.mk

index 699561b9ab6054e17835b882f6ee742dbeab6ea4..e64989dffd845ef5be98503fdb7f4b3c9d77c6e1 100644 (file)
@@ -22,5 +22,14 @@ endef
 
 LIBPNG_POST_INSTALL_STAGING_HOOKS += LIBPNG_STAGING_LIBPNG12_CONFIG_FIXUP
 
+define LIBPNG_REMOVE_CONFIG_SCRIPTS
+       $(RM) -f $(TARGET_DIR)/usr/bin/libpng$(LIBPNG_SERIES)-config \
+                $(TARGET_DIR)/usr/bin/libpng-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+LIBPNG_POST_INSTALL_TARGET_HOOKS += LIBPNG_REMOVE_CONFIG_SCRIPTS
+endif
+
 $(eval $(call AUTOTARGETS,package,libpng))
 $(eval $(call AUTOTARGETS,package,libpng,host))