syslinux: remove host variant
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 09:55:15 +0000 (11:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 09:55:15 +0000 (11:55 +0200)
The host variant of syslinux wasn't exposed anywhere, so the only way
to use it was to know that a "host-syslinux" target existed. Moreover,
thanks to commit 8e0d4118982ae5a29e462f0a476d82772459cf5c ('syslinux:
install helper programs to the host'), the host utilities of syslinux
are automatically installed to $(HOST_DIR) when building the target
syslinux.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/syslinux/syslinux.mk

index 7b3f9cf3616b88b96c04b38dfe2649432b10e217..0faa81f6e25d939d51cc0c289841c0e5aded5d05 100644 (file)
@@ -37,14 +37,4 @@ define SYSLINUX_INSTALL_IMAGES_CMDS
        done
 endef
 
-
-define HOST_SYSLINUX_BUILD_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
-endef
-
-define HOST_SYSLINUX_INSTALL_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) INSTALLROOT=$(HOST_DIR) install
-endef
-
 $(eval $(generic-package))
-$(eval $(host-generic-package))