berkeleydb: workaround m68k/coldfire issue
authorWaldemar Brodkorb <wbx@openadk.org>
Wed, 22 Feb 2017 12:51:10 +0000 (13:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Feb 2017 20:33:21 +0000 (21:33 +0100)
Fixes:
 http://autobuild.buildroot.net/results/40423aa6c8f6fe66c771cca3e09b21e15525eb5f

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
[Thomas: rename BERKELEYDB_CONF_OPTS to BERKELEYDB_CONF_ENV.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/berkeleydb/berkeleydb.mk

index e5c11bddcf1e5969e14f2c9b06a5851b47bea0c7..a315943ee6fd041910e60bebab42254700720657 100644 (file)
@@ -20,11 +20,18 @@ BERKELEYDB_BINARIES = db_archive db_checkpoint db_deadlock db_dump \
        db_hotbackup db_load db_log_verify db_printlog db_recover db_replicate \
        db_stat db_tuner db_upgrade db_verify
 
+# Internal error, aborting at dw2gencfi.c:214 in emit_expr_encoded
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79509
+ifeq ($(BR2_m68k_cf),y)
+BERKELEYDB_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -fno-dwarf2-cfi-asm"
+endif
+
 # build directory can't be the directory where configure are there, so..
 define BERKELEYDB_CONFIGURE_CMDS
        (cd $(@D)/build_unix; rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                $(TARGET_CONFIGURE_ARGS) \
+               $(BERKELEYDB_CONF_ENV) \
                ../dist/configure $(QUIET) \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \