package/pipewire: add missing dependencies/plugins
authorJames Hilliard <james.hilliard1@gmail.com>
Wed, 18 Dec 2019 13:04:59 +0000 (06:04 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Dec 2019 22:33:08 +0000 (23:33 +0100)
Added missing required and optional dependencies.
Provide option to enable gstreamer plugin.

Fixes:

  http://autobuild.buildroot.net/results/9671ad63b1ae147a6f660337cb4b3dc38209067c/
  http://autobuild.buildroot.net/results/0e80841fe9937d7a5142035c2a41158166bcf8df/

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[Thomas:
 - enclose new option in if ... endif block
 - add missing Config.in comment
 - add dependency on gstreamer1 in .mk file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pipewire/Config.in
package/pipewire/pipewire.mk

index ca23e6cff02df213fe498ceb8fea3cb66f71e631..d7a4a51b3898ee2ecb7596d7b12513c2f2ce30fd 100644 (file)
@@ -1,7 +1,9 @@
 menuconfig BR2_PACKAGE_PIPEWIRE
        bool "pipewire"
-       depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
+       depends on BR2_PACKAGE_HAS_UDEV # libudev
+       depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, alsa-lib
        depends on BR2_USE_MMU # dbus
+       select BR2_PACKAGE_ALSA_LIB
        select BR2_PACKAGE_DBUS
        help
          PipeWire is a server and user space API to deal with
@@ -9,6 +11,25 @@ menuconfig BR2_PACKAGE_PIPEWIRE
 
          https://pipewire.org/
 
+if BR2_PACKAGE_PIPEWIRE
+
+config BR2_PACKAGE_PIPEWIRE_GSTREAMER
+       bool "pipewire gstreamer plugins"
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_GSTREAMER1
+       select BR2_PACKAGE_GST1_PLUGINS_BASE
+       help
+         Build GStreamer plugins
+
+comment "pipewire gstreamer support needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
+endif
+
 comment "pipewire needs a toolchain w/ threads"
        depends on BR2_USE_MMU
        depends on !BR2_TOOLCHAIN_HAS_THREADS
index 7717095535bc75c80537795ec15ea4eb81bb493a..ed98ff7f3b6e9430cd87a50229ed5ee387004c85 100644 (file)
@@ -9,8 +9,26 @@ PIPEWIRE_SITE = $(call github,PipeWire,pipewire,$(PIPEWIRE_VERSION))
 PIPEWIRE_LICENSE = LGPL-2.1+
 PIPEWIRE_LICENSE_FILES = LICENSE LGPL
 PIPEWIRE_INSTALL_STAGING = YES
-PIPEWIRE_DEPENDENCIES = host-pkgconf dbus
-PIPEWIRE_CONF_OPTS = -Dgstreamer=disabled
+PIPEWIRE_DEPENDENCIES = host-pkgconf alsa-lib dbus udev
+
+ifeq ($(BR2_PACKAGE_FFMPEG),y)
+PIPEWIRE_DEPENDENCIES += ffmpeg
+endif
+
+ifeq ($(BR2_PACKAGE_SBC),y)
+PIPEWIRE_DEPENDENCIES += sbc
+endif
+
+ifeq ($(BR2_PACKAGE_SDL2),y)
+PIPEWIRE_DEPENDENCIES += sdl2
+endif
+
+ifeq ($(BR2_PACKAGE_PIPEWIRE_GSTREAMER),y)
+PIPEWIRE_CONF_OPTS += -Dgstreamer=enabled
+PIPEWIRE_DEPENDENCIES += libglib2 gstreamer1 gst1-plugins-base
+else
+PIPEWIRE_CONF_OPTS += -Dgstreamer=disabled
+endif
 
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 PIPEWIRE_CONF_OPTS += -Dsystemd=true