- don't try to strip the gccbug script
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 1 Sep 2007 17:11:24 +0000 (17:11 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 1 Sep 2007 17:11:24 +0000 (17:11 -0000)
toolchain/gcc/gcc-uclibc-4.x.mk

index 1a3f80aadebfa754a3fe8a6e10659f94a170b155..2fad23fd71d475761c3f594a27b01239c330cf0c 100644 (file)
@@ -291,7 +291,7 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
                $(STAGING_DIR)/usr/bin/$(GNU_TARGET_NAME)-gccbug
        # Strip the host binaries
 ifeq ($(GCC_STRIP_HOST_BINARIES),true)
-       -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*
+       strip --strip-all -R .note -R .comment $(filter-out -gccbug,$(wildcard $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-*))
        -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/faked
 endif
        # Make sure we have 'cc'.