vlc: ensure correct directfb-config is used
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 4 May 2015 14:27:10 +0000 (16:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 May 2015 14:27:10 +0000 (16:27 +0200)
Otherwise we can end up using host includes/libraries if the build host has
directfb-config.

Fixes:
http://autobuild.buildroot.net/results/361/3612b54b0bbc2a55ba6f0febb7be32595b523d96/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/vlc.mk

index ab9aaaee3c4a26f7184e52b47b92362e10924037..acd67ee0f1e08c2003ef8b09001539266643d288 100644 (file)
@@ -88,6 +88,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_DIRECTFB),y)
 VLC_CONF_OPTS += --enable-directfb
+VLC_CONF_ENV += ac_cv_path_DIRECTFB_CONFIG=$(STAGING_DIR)/usr/bin/directfb-config
 VLC_DEPENDENCIES += directfb
 else
 VLC_CONF_OPTS += --disable-directfb