bluez5_utils: Make systemd link correctly
authorTrent Piepho <tpiepho@impinj.com>
Tue, 27 Feb 2018 21:21:31 +0000 (13:21 -0800)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 27 Feb 2018 21:44:17 +0000 (22:44 +0100)
The link in /etc/systemd/system/, named dbus-org.bluez.service, pointing to
../../../../usr/lib/systemd/system/bluetooth.service has one too many ".." in
it.  Likely the target was copied from the other link in
/etc/systemd/system/bluetooth.target.wants/, which is one level deeper.

Adjust link to be correct.

Signed-off-by: Trent Piepho <tpiepho@impinj.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bluez5_utils/bluez5_utils.mk

index 0634ec9f6f354729d02ee06bd3b66ae02b7c7d47..395340a3e672e88aedeb90eb6a4ab1a18558b156 100644 (file)
@@ -116,7 +116,7 @@ define BLUEZ5_UTILS_INSTALL_INIT_SYSTEMD
        mkdir -p $(TARGET_DIR)/etc/systemd/system/bluetooth.target.wants
        ln -fs ../../../../usr/lib/systemd/system/bluetooth.service \
                $(TARGET_DIR)/etc/systemd/system/bluetooth.target.wants/bluetooth.service
-       ln -fs ../../../../usr/lib/systemd/system/bluetooth.service \
+       ln -fs ../../../usr/lib/systemd/system/bluetooth.service \
                $(TARGET_DIR)/etc/systemd/system/dbus-org.bluez.service
 endef