package/systemd: add missing path options
authorNorbert Lange <nolange79@gmail.com>
Fri, 10 Jul 2020 23:41:48 +0000 (01:41 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Nov 2020 21:17:55 +0000 (22:17 +0100)
If paths are not set, then meson will search the host system for the
binaries (or the target, where those binaries are not yet installed).
So add the missing paths.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Reviewed-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/systemd/systemd.mk

index 6f04283bdccc51ba527bbe6028d9dc9efece058f..50416cceb61df6720b4370dbed409041df5c8ecb 100644 (file)
@@ -37,11 +37,15 @@ SYSTEMD_CONF_OPTS += \
        -Dsystem-uid-max=999 \
        -Dsystem-gid-max=999 \
        -Dtelinit-path=$(TARGET_DIR)/sbin/telinit \
+       -Dquotaon-path=/usr/sbin/quotaon \
+       -Dquotacheck-path=/usr/sbin/quotacheck \
        -Dkmod-path=/usr/bin/kmod \
        -Dkexec-path=/usr/sbin/kexec \
        -Dsulogin-path=/usr/sbin/sulogin \
        -Dmount-path=/usr/bin/mount \
        -Dumount-path=/usr/bin/umount \
+       -Dloadkeys-path=/usr/bin/loadkeys \
+       -Dsetfont-path=/usr/bin/setfont \
        -Didn=true \
        -Dnss-systemd=true \
        -Dportabled=false