toolchain: get rid of unused gcc 3.x legacy handling
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 4 Dec 2009 19:34:03 +0000 (20:34 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 4 Dec 2009 19:34:03 +0000 (20:34 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/binutils/binutils.mk
toolchain/gcc/Makefile.in
toolchain/gcc/gcc-uclibc-3.x.mk

index e482a8ae023df1048eebd58f6700f1035a3286d7..8cddf2d50173bf316cb67371acc6165994982828 100644 (file)
@@ -27,9 +27,6 @@ endif
 BINUTILS_HOST_PREREQ:=
 BINUTILS_TARGET_PREREQ:=
 
-ifeq ($(findstring x3.,x$(GCC_VERSION)),x3.)
-BINUTILS_NO_MPFR:=y
-endif
 ifeq ($(findstring x4.0,x$(GCC_VERSION)),x4.0)
 BINUTILS_NO_MPFR:=y
 endif
index e052b83b46d6a9e50b6b7c45a84aaf2c5eeb94e3..e92ecbc7b5b0362e74aea6a43ee9d216a5f2fa0c 100644 (file)
@@ -19,17 +19,6 @@ GCC_USE_SJLJ_EXCEPTIONS:=--enable-sjlj-exceptions
 endif
 
 ifeq ($(BR2_SOFT_FLOAT),y)
-# gcc 3.4.x soft float configuration is different than previous versions.
-ifeq ($(findstring x3.4.,x$(GCC_VERSION)),x3.4.)
-ifneq ($(BR2_nios2),y)
-SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
-endif
-else
-SOFT_FLOAT_CONFIG_OPTION:=--without-float
-endif
-
-# again... there must be a better way
-ifeq ($(findstring x4.,x$(GCC_VERSION)),x4.)
 SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
 ifeq ($(BR2_SOFT_FLOAT_FP),y)
 TARGET_SOFT_FLOAT:=-mfloat-abi=softfp
@@ -40,9 +29,6 @@ else
 TARGET_SOFT_FLOAT:=-msoft-float
 endif
 endif
-else # not gcc-4.x
-TARGET_SOFT_FLOAT:=-msoft-float
-endif
 ARCH_FPU_SUFFIX:=_nofpu
 else # no softfloat support
 SOFT_FLOAT_CONFIG_OPTION:=
@@ -89,10 +75,7 @@ endif
 EXTRA_TARGET_GCC_CONFIG_OPTIONS+=$(call qstrip,$(BR2_EXTRA_TARGET_GCC_CONFIG_OPTIONS))
 
 ifeq ($(BR2_PREFER_IMA),y)
-# >= 4.x
-ifneq ($(findstring x3.,x$(GCC_VERSION)),x3.)
 EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--enable-intermodule
-endif
 endif # BR2_PREFER_IMA=y
 
 TARGETS+=gcc_target
index 6531bfccb4b3f8d79f675c1c47599d8a9be2a2a5..e73731348851430ce31c02ae7eba566ee2caea1c 100644 (file)
@@ -57,9 +57,6 @@ endif
 GCC_CAT:=$(BZCAT)
 GCC_STRIP_HOST_BINARIES:=true
 
-ifeq ($(findstring x3.,x$(GCC_VERSION)),x3.)
-GCC_NO_MPFR:=y
-else
 ifneq ($(BR2_INSTALL_FORTRAN),y)
 # fortran needs gmp and mpfr
 ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
@@ -69,7 +66,6 @@ ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
 GCC_NO_MPFR:=y
 endif
 endif
-endif
 
 #############################################################
 #