package/uvw: disable CMake pthread test
authorAsaf Kahlon <asafka7@gmail.com>
Sun, 27 Oct 2019 20:30:27 +0000 (22:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 27 Oct 2019 20:32:28 +0000 (21:32 +0100)
Fixes:
 - http://autobuild.buildroot.net/results/9c61c06142c832a9669afdcafcbb8b1f7df51082

Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/uvw/uvw.mk

index 64122aea44540d3d793fddf221862cad082e308b..2e46721b52c2af73fed2c360afce4267b349eba4 100644 (file)
@@ -13,4 +13,8 @@ UVW_DEPENDENCIES = libuv
 UVW_LICENSE = MIT
 UVW_LICENSE_FILES = LICENSE
 
+# The following CMake variable disables a TRY_RUN call in the -pthread
+# test which is not allowed when cross-compiling (for cmake < 3.10)
+UVW_CONF_OPTS = -DTHREADS_PTHREAD_ARG=OFF
+
 $(eval $(cmake-package))