package/collectd: add amqp support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 9 Jun 2019 16:57:30 +0000 (18:57 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 9 Jun 2019 22:39:40 +0000 (00:39 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/collectd/Config.in
package/collectd/collectd.mk

index 0cf04b51800565cb61487393ed2a464826b745f3..31103634293825be43de8cfbdc643303405a7dd5 100644 (file)
@@ -524,6 +524,13 @@ menu "write plugins"
 
 comment "Select at least one for collectd to be useful"
 
+config BR2_PACKAGE_COLLECTD_AMQP
+       bool "amqp"
+       select BR2_PACKAGE_RABBITMQ_C
+       help
+         Send/receive values via the Advanced Message Queuing Protocol
+         (AMQP).
+
 config BR2_PACKAGE_COLLECTD_CSV
        bool "csv"
        help
index 027df8f111b827000edce87841153c98a221d578..531b824b268bb325b3bc25b44f57098636ea6546 100644 (file)
@@ -14,7 +14,7 @@ COLLECTD_LICENSE_FILES = COPYING libltdl/COPYING.LIB
 
 # These require unmet dependencies, are fringe, pointless or deprecated
 COLLECTD_PLUGINS_DISABLE = \
-       amqp apple_sensors aquaero ascent barometer dbi dpdkstat email \
+       apple_sensors aquaero ascent barometer dbi dpdkstat email \
        gmond grpc hddtemp intel_rdt ipmi java libvirt lpar lua lvm \
        madwifi mbmon mic multimeter netapp notify_desktop numa \
        nut onewire oracle perl pf pinba powerdns python redis routeros \
@@ -45,6 +45,7 @@ COLLECTD_CONF_OPTS += \
        --disable-werror \
        $(foreach p, $(COLLECTD_PLUGINS_DISABLE), --disable-$(p)) \
        $(if $(BR2_PACKAGE_COLLECTD_AGGREGATION),--enable-aggregation,--disable-aggregation) \
+       $(if $(BR2_PACKAGE_COLLECTD_AMQP),--enable-amqp,--disable-amqp) \
        $(if $(BR2_PACKAGE_COLLECTD_APACHE),--enable-apache,--disable-apache) \
        $(if $(BR2_PACKAGE_COLLECTD_APCUPS),--enable-apcups,--disable-apcups) \
        $(if $(BR2_PACKAGE_COLLECTD_BATTERY),--enable-battery,--disable-battery) \
@@ -141,6 +142,7 @@ COLLECTD_CONF_OPTS += \
 
 COLLECTD_DEPENDENCIES = \
        host-pkgconf \
+       $(if $(BR2_PACKAGE_COLLECTD_AMQP),rabbitmq-c) \
        $(if $(BR2_PACKAGE_COLLECTD_APACHE),libcurl) \
        $(if $(BR2_PACKAGE_COLLECTD_BIND),libcurl libxml2) \
        $(if $(BR2_PACKAGE_COLLECTD_CEPH),yajl) \