boot/opensbi: move patches to 0.9/ subdir to only apply when the 0.9 version is selected
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 12 May 2021 08:41:02 +0000 (10:41 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 13 May 2021 07:48:24 +0000 (09:48 +0200)
With the addition of support for custom opensbi version in commit
5c7166d387b (boot/opensbi: add support for version configuration), we can no
longer be sure that the Buildroot patches can be applied - So move them to a
0.9 subdir to ensure they are only applied when the _LATEST_VERSION is used.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/opensbi/0.9/0001-Makefile-Don-t-specify-mabi-or-march.patch [new file with mode: 0644]
boot/opensbi/0.9/0002-Makefile-unconditionally-disable-SSP.patch [new file with mode: 0644]
boot/opensbi/0001-Makefile-Don-t-specify-mabi-or-march.patch [deleted file]
boot/opensbi/0002-Makefile-unconditionally-disable-SSP.patch [deleted file]

diff --git a/boot/opensbi/0.9/0001-Makefile-Don-t-specify-mabi-or-march.patch b/boot/opensbi/0.9/0001-Makefile-Don-t-specify-mabi-or-march.patch
new file mode 100644 (file)
index 0000000..5f554a6
--- /dev/null
@@ -0,0 +1,37 @@
+From f5871e1f3650d6c8a032928cb5d8ca00c275c377 Mon Sep 17 00:00:00 2001
+From: Alistair Francis <alistair.francis@wdc.com>
+Date: Fri, 15 Feb 2019 14:57:41 -0800
+Subject: [PATCH] Makefile: Don't specify mabi or march
+
+To avoid
+    can't link double-float modules with soft-float modules
+errors when building 32-bit openSBI don't specify mabi or march.
+
+Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
+---
+ Makefile | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ae68f55..10851fc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -145,7 +145,6 @@ GENFLAGS   +=      $(firmware-genflags-y)
+ CFLAGS                =       -g -Wall -Werror -nostdlib -fno-strict-aliasing -O2
+ CFLAGS                +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
+ CFLAGS                +=      -mno-save-restore -mstrict-align
+-CFLAGS                +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
+ CFLAGS                +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
+ CFLAGS                +=      $(GENFLAGS)
+ CFLAGS                +=      $(platform-cflags-y)
+@@ -158,7 +157,6 @@ CPPFLAGS   +=      $(firmware-cppflags-y)
+ ASFLAGS               =       -g -Wall -nostdlib -D__ASSEMBLY__
+ ASFLAGS               +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
+ ASFLAGS               +=      -mno-save-restore -mstrict-align
+-ASFLAGS               +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
+ ASFLAGS               +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
+ ASFLAGS               +=      $(GENFLAGS)
+ ASFLAGS               +=      $(platform-asflags-y)
+-- 
+2.20.1
+
diff --git a/boot/opensbi/0.9/0002-Makefile-unconditionally-disable-SSP.patch b/boot/opensbi/0.9/0002-Makefile-unconditionally-disable-SSP.patch
new file mode 100644 (file)
index 0000000..c4edd37
--- /dev/null
@@ -0,0 +1,53 @@
+From e389d5fbc296e496db15368b2b621e0f178f7f34 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sat, 8 May 2021 21:28:10 +0200
+Subject: [PATCH] Makefile: unconditionally disable SSP
+
+Though -nostdlib is passed in {C,+AS,DTSCPP}FLAGS, -fno-stack-protector
+must also be passed to avoid linking errors related to undefined
+references to '__stack_chk_guard' and '__stack_chk_fail' if toolchain
+enforces -fstack-protector.
+
+Fixes:
+ - https://gitlab.com/kubu93/buildroot/-/jobs/1247043359
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://github.com/riscv/opensbi/pull/211]
+---
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index eeffe6b..1419360 100644
+--- a/Makefile
++++ b/Makefile
+@@ -203,7 +203,7 @@ GENFLAGS   +=      $(libsbiutils-genflags-y)
+ GENFLAGS      +=      $(platform-genflags-y)
+ GENFLAGS      +=      $(firmware-genflags-y)
+-CFLAGS                =       -g -Wall -Werror -ffreestanding -nostdlib -fno-strict-aliasing -O2
++CFLAGS                =       -g -Wall -Werror -ffreestanding -nostdlib -fno-stack-protector -fno-strict-aliasing -O2
+ CFLAGS                +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
+ CFLAGS                +=      -mno-save-restore -mstrict-align
+ CFLAGS                +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
+@@ -217,7 +217,7 @@ CPPFLAGS   +=      $(GENFLAGS)
+ CPPFLAGS      +=      $(platform-cppflags-y)
+ CPPFLAGS      +=      $(firmware-cppflags-y)
+-ASFLAGS               =       -g -Wall -nostdlib -D__ASSEMBLY__
++ASFLAGS               =       -g -Wall -nostdlib -fno-stack-protector -D__ASSEMBLY__
+ ASFLAGS               +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
+ ASFLAGS               +=      -mno-save-restore -mstrict-align
+ ASFLAGS               +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
+@@ -236,7 +236,7 @@ MERGEFLAGS +=      -r
+ MERGEFLAGS    +=      -b elf$(PLATFORM_RISCV_XLEN)-littleriscv
+ MERGEFLAGS    +=      -m elf$(PLATFORM_RISCV_XLEN)lriscv
+-DTSCPPFLAGS   =       $(CPPFLAGS) -nostdinc -nostdlib -fno-builtin -D__DTS__ -x assembler-with-cpp
++DTSCPPFLAGS   =       $(CPPFLAGS) -nostdinc -nostdlib -fno-stack-protector -fno-builtin -D__DTS__ -x assembler-with-cpp
+ # Setup functions for compilation
+ define dynamic_flags
+-- 
+2.30.2
+
diff --git a/boot/opensbi/0001-Makefile-Don-t-specify-mabi-or-march.patch b/boot/opensbi/0001-Makefile-Don-t-specify-mabi-or-march.patch
deleted file mode 100644 (file)
index 5f554a6..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From f5871e1f3650d6c8a032928cb5d8ca00c275c377 Mon Sep 17 00:00:00 2001
-From: Alistair Francis <alistair.francis@wdc.com>
-Date: Fri, 15 Feb 2019 14:57:41 -0800
-Subject: [PATCH] Makefile: Don't specify mabi or march
-
-To avoid
-    can't link double-float modules with soft-float modules
-errors when building 32-bit openSBI don't specify mabi or march.
-
-Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
----
- Makefile | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index ae68f55..10851fc 100644
---- a/Makefile
-+++ b/Makefile
-@@ -145,7 +145,6 @@ GENFLAGS   +=      $(firmware-genflags-y)
- CFLAGS                =       -g -Wall -Werror -nostdlib -fno-strict-aliasing -O2
- CFLAGS                +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
- CFLAGS                +=      -mno-save-restore -mstrict-align
--CFLAGS                +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
- CFLAGS                +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
- CFLAGS                +=      $(GENFLAGS)
- CFLAGS                +=      $(platform-cflags-y)
-@@ -158,7 +157,6 @@ CPPFLAGS   +=      $(firmware-cppflags-y)
- ASFLAGS               =       -g -Wall -nostdlib -D__ASSEMBLY__
- ASFLAGS               +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
- ASFLAGS               +=      -mno-save-restore -mstrict-align
--ASFLAGS               +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
- ASFLAGS               +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
- ASFLAGS               +=      $(GENFLAGS)
- ASFLAGS               +=      $(platform-asflags-y)
--- 
-2.20.1
-
diff --git a/boot/opensbi/0002-Makefile-unconditionally-disable-SSP.patch b/boot/opensbi/0002-Makefile-unconditionally-disable-SSP.patch
deleted file mode 100644 (file)
index c4edd37..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From e389d5fbc296e496db15368b2b621e0f178f7f34 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sat, 8 May 2021 21:28:10 +0200
-Subject: [PATCH] Makefile: unconditionally disable SSP
-
-Though -nostdlib is passed in {C,+AS,DTSCPP}FLAGS, -fno-stack-protector
-must also be passed to avoid linking errors related to undefined
-references to '__stack_chk_guard' and '__stack_chk_fail' if toolchain
-enforces -fstack-protector.
-
-Fixes:
- - https://gitlab.com/kubu93/buildroot/-/jobs/1247043359
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/riscv/opensbi/pull/211]
----
- Makefile | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index eeffe6b..1419360 100644
---- a/Makefile
-+++ b/Makefile
-@@ -203,7 +203,7 @@ GENFLAGS   +=      $(libsbiutils-genflags-y)
- GENFLAGS      +=      $(platform-genflags-y)
- GENFLAGS      +=      $(firmware-genflags-y)
--CFLAGS                =       -g -Wall -Werror -ffreestanding -nostdlib -fno-strict-aliasing -O2
-+CFLAGS                =       -g -Wall -Werror -ffreestanding -nostdlib -fno-stack-protector -fno-strict-aliasing -O2
- CFLAGS                +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
- CFLAGS                +=      -mno-save-restore -mstrict-align
- CFLAGS                +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
-@@ -217,7 +217,7 @@ CPPFLAGS   +=      $(GENFLAGS)
- CPPFLAGS      +=      $(platform-cppflags-y)
- CPPFLAGS      +=      $(firmware-cppflags-y)
--ASFLAGS               =       -g -Wall -nostdlib -D__ASSEMBLY__
-+ASFLAGS               =       -g -Wall -nostdlib -fno-stack-protector -D__ASSEMBLY__
- ASFLAGS               +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
- ASFLAGS               +=      -mno-save-restore -mstrict-align
- ASFLAGS               +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
-@@ -236,7 +236,7 @@ MERGEFLAGS +=      -r
- MERGEFLAGS    +=      -b elf$(PLATFORM_RISCV_XLEN)-littleriscv
- MERGEFLAGS    +=      -m elf$(PLATFORM_RISCV_XLEN)lriscv
--DTSCPPFLAGS   =       $(CPPFLAGS) -nostdinc -nostdlib -fno-builtin -D__DTS__ -x assembler-with-cpp
-+DTSCPPFLAGS   =       $(CPPFLAGS) -nostdinc -nostdlib -fno-stack-protector -fno-builtin -D__DTS__ -x assembler-with-cpp
- # Setup functions for compilation
- define dynamic_flags
--- 
-2.30.2
-